思科模拟器配置-基本操作和vlan实训

标签: 思科模拟器配置  思科  思科模拟器  vlan

根据下面的拓扑图进行配置,保证全网互通,VLAN间能互通

在这里插入图片描述

S1上配置VTY登录,限制3台主机,保存运行配置到启动配置文件。

S1(config)#line vty 0 2
S1(config-line)#exit
S1(config)#exit
S1#copy running-config startup-config 
Destination filename [startup-config]? 
Building configuration...
[OK]

S1使用本地数据库验证方式,添加用户a1:1234。配置特权加密口令为2345。

S1(config)#line vty 0 2
S1(config-line)#login local
S1(config-line)#exit
S1(config)#username a1 password 1234
S1(config)#enable password 2345

给各交换机配置VLAN,VLAN管理地址均为本网段最后一个地址。

S1:

S1(config)#vlan 50
S1(config-vlan)#vlan 60
S1(config-vlan)#exit
S1(config)#interface vlan 50
S1(config-if)#
%LINK-5-CHANGED: Interface Vlan50, changed state to up
S1(config-if)#ip address 172.0.50.254 255.255.255.0
S1(config-if)#exit
S1(config)#interface vlan 60
S1(config-if)#
%LINK-5-CHANGED: Interface Vlan60, changed state to up
S1(config-if)#ip address 172.0.60.254 255.255.255.0

S2:

S2(config)#vlan 10
S2(config-vlan)#vlan 20
S2(config-vlan)#exit
S2(config)#interface vlan 10
S2(config-if)#
%LINK-5-CHANGED: Interface Vlan10, changed state to up
S2(config-if)#ip address 172.0.10.254 255.255.255.0
S2(config-if)#exit
S2(config)#interface vlan 20
S2(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up
S2(config-if)#ip address 172.0.20.254 255.255.255.0

S1上配单臂路由,S3上配三层交换路由。

配置各pc ip
在这里插入图片描述

S1:

S1(config)#interface fastEthernet 0/5
S1(config-if)#switchport mode access 
S1(config-if)#switchport access vlan 50
S1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan50, changed state to up
S1(config-if)#exit
S1(config)#interface fastEthernet 0/6
S1(config-if)#switchport mode access 
S1(config-if)#switchport access vlan 60
S1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan60, changed state to up
S1(config-if)#exit
S1(config)#interface fastEthernet 0/1
S1(config-if)#switchport mode trunk 
S1(config-if)#

R1:

R1#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface fastEthernet 0/0
R1(config-if)#no shutdown 
R1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#interface fastEthernet 0/0.50
R1(config-subif)#
R1(config-subif)#ip add
R1(config-subif)#ip address 172.0.50.1 255.255.255.0
R1(config-subif)#encapsulation dot1Q 50
R1(config-subif)#ip address 172.0.50.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface fastEthernet 0/0.60
R1(config-subif)#
R1(config-subif)#encapsulation dot1Q 60
R1(config-subif)#ip address 172.0.60.1 255.255.255.0
R1(config-subif)#

验证可用性:
在这里插入图片描述

S2:
在这里插入图片描述

S2(config)#vlan 10
S2(config-vlan)#vlan 20
S2(config-vlan)#exit
S2(config)#interface fastEthernet 0/1
S2(config-if)#switchport mode access 
S2(config-if)#switchport access vlan 10
S2(config-if)#exit
S2(config)#interface fastEthernet 0/6
S2(config-if)#switchport mode access 
S2(config-if)#switchport access vlan 20
S2(config-if)#exit
S2(config)#interface fastEthernet 0/20
S2(config-if)#switchport mode trunk 

S3:

S3(config)#vlan 10
S3(config-vlan)#vlan 20
S3(config-vlan)#exit
S3(config)#interface fastEthernet 0/1
S3(config-if)#switchport mode access 
S3(config-if)#switchport access vlan 10
S3(config-if)#exit
S3(config)#interface fastEthernet 0/6
S3(config-if)#switchport mode access 
S3(config-if)#switchport access vlan 20
S3(config-if)#exit
S3(config)#ip routing

三层路由验证:

在这里插入图片描述

R0清除密码和所有配置,再配静态路由。

R0:

R0#erase startup-config
R0(config)#interface fastEthernet 0/1
R0(config-if)#no shutdown 
R0(config-if)#ip address 192.168.1.2 255.255.255.0
R0(config-if)#exit
R0(config)#interface fastEthernet 0/0
R0(config-if)#no shutdown 
R0(config-if)#ip address 192.168.0.1 255.255.255.0
R0(config-if)#exit
R0(config)#interface fastEthernet 1/0
R0(config-if)#no shutdown 
R0(config-if)#ip address 192.168.3.1 255.255.255.0
R0(config)#ip route 172.0.50.0 255.255.255.0 192.168.3.2
R0(config)#ip route 172.0.60.0 255.255.255.0 192.168.3.2
R0(config)#ip route 172.0.10.0 255.255.255.0 192.168.1.1
R0(config)#ip route 172.0.20.0 255.255.255.0 192.168.1.1

S3:

S3(config)#in fastEthernet 0/24
S3(config-if)#no switchport
S3(config-if)#ip address 192.168.1.1 255.255.255.0
S3(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2

在这里插入图片描述

R1配置默认路由,保存配置文件,并复制到server0的TFTP服务器。

R1(config)#interface fastEthernet 0/1
R1(config-if)#no shutdown 
R1(config-if)#ip address 192.168.3.2 255.255.255.0
R1(config-if)#exit
R1(config)#
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.3.1

在这里插入图片描述

服务器:

在这里插入图片描述

R1#copy running-config tftp
Address or name of remote host []? 192.168.0.2
Destination filename [R1-confg]? y

Writing running-config...!!
[OK - 787 bytes]

787 bytes copied in 0 secs
R1#

在这里插入图片描述

END:

在这里插入图片描述
在这里插入图片描述

版权声明:本文为qq_38626043原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/qq_38626043/article/details/109524663

智能推荐

一致性hash算法

散列(hash)在我看来就是一个数组,而与数组不同的点在于数组是按顺序写入的,而hash是按照一定的hash算法确定元素在数组中的位置的。hash最难的问题在于会有冲突出现,如果两个object根据相应的hash算法得出的值一样便产生了hash冲突。在所有解决hash冲突的方法中,我最欣赏的是链式解决法,即将hash到同一位置的元素用链表连接。当然还有其它几种处理hash冲突的算法,比如建立公共溢...

OpenCV-Python learning-1.安装,图片读取显示

1. OpenCV与OpenGL区别 https://www.zhihu.com/question/20212016 一个是让机器识别东西的,OpenCV是给电脑做眼睛的。 一个是让机器计算出更好画面的,OpenGL用在游戏渲染方面很多。 OpenCV(Open Source Computer Vision Library)是一个基于(开源)发行的跨平台计算机视觉库,OpenGL(全写Open G...

Mycat+Mysql分布式架构改造和性能压力测试

架构实现 Mycat作为数据库高可用中间件具备很多的功能,如负载均衡,分库分表,读写分离,故障迁移等。结合项目的实际情况,分库分表功能对于关联查询有很高的要求,需要从业务角度考虑分库分表后的关联查询SQL的分析,业务代码动作较大,所以在此方案中我们不考虑分库分表。主要应用Mycat的负载均衡及故障迁移的功能即可。 整个架构改造包括两个部分,第一是单例Mysql改为多个Mysql,同时负载均衡,并且...

人脸识别之疲劳检测(二)阈值法、KNN分类和K-means聚类

Table of Contents 1、均值法 2、中值法 3、KNN 4、K-means 结合上一节在获得人眼特征点后需要对睁眼闭眼状态做出判断,方法的选择需要经验结合公平的评价方法,使用大量测试集得到不同方法下的精确度并做出比较: 1、均值法 50帧睁眼数据取均值,得到不同阈值下精确度。 2、中值法 50帧睁眼数据取中值,得到不同阈值下精确度。 3、KNN KNN是一种ML常用分类算法,通过测...

CodeForce Tic-Tac-Toe

Two bears are playing tic-tac-toe via mail. It's boring for them to play usual tic-tac-toe game, so they are a playing modified version of this game. Here are its rules. The game is played on the foll...

猜你喜欢

Python雾里看花-抽象类ABC (abstract base class)

首先认识模块 abc,python中没有提供抽象类与抽象方法,然而提供了内置模块abc来模拟实现抽象类,例如提供泛映射类型的抽象类 abc.MutableMapping 继承abc.MutableMapping构造一个泛映射类型(类似python中的dict) 当然继承abc.Mapping 也可以,毕竟MutableMapping是其子类 dict是python中典型的映射类型数据结构,其接口的...

python 文件操作

2, with open (‘xx.txt’,‘w’,encoding=‘utf-8’) as f: f.write(‘文件内容或对象’)...

【Python基础】使用统计函数绘制简单图形

机器学习算法与自然语言处理出品 @公众号原创专栏作者 冯夏冲 学校 | 哈工大SCIR实验室在读博士生 2.1 函数bar 用于绘制柱状图 2.2 函数barh 用于绘制条形图 2.3 函数hist 用于绘制直方图 直方图与柱状图的区别 函数pie 用于绘制饼图 2.5 函数polor 用于绘制极线图 极线图是在极坐标系上绘出的一种图。在极坐标系中,要确定一个点,需要指明这个点距原点的角...

css:顶部按钮固定,上面内容滑动

这种需求我们平时见到很多的,实现方法也多的参差不齐,下面我说一种简单的。如图: 可以看到只有红线部分滚动,底下按钮是固定的。 代码...

环形公路堵车概率模型(含详细解析)

文章目录 基础理论 代码实现 图形分析 基础理论 路面上有n辆车,以不同的速度向前行驶, 模拟堵车问题。 有以下假设: 假设某辆车的当前速度是v。 若前方可见范围内没车,则它在下一秒的车速提高到v+1,直到达到规定的最高限速。 若前方有车,前车的距离为d,且d < v,则它下 一秒的车速降低到d-1 。 每辆车会以概率p随机减速v-1。、 代码实现 图形分析 图形中颜色越重的地方,说明很多车...